Problem
- A Windows 7 SP1 or Windows 8.1 based machine takes a long time trying to check for available updates. It either never completes, or takes many hours.
- Such a machine likely has not installed or checked for updates for a significant period of time.
Cause
This issue is caused by changes to Windows Update servers at Microsoft's end, meaning that updated Windows Update components are required to resolve this problem.
Resolution
Update the required components using the steps below.
Steps - Windows 7
- Stop the Windows Update Service.
- Install the April 2015 Servicing Stack Update.
- Download 32bit here.
- Download 64bit here.
- Reboot the system.
- Stop the Windows Update Service again.
- Install the July 2016 Update Rollup.
- Download 32bit here.
- Download 64bit here.
- Reboot the machine again.
- Ensure the Windows Update Service is running
- Attempt Windows Updates again.
Steps - Windows 8.1 with Update
- Stop the Windows Update Service.
- Install the July 2016 Servicing Stack Update.
- Reboot if prompted to do so.
- Stop the Windows Update Service again.
- Install the July 2016 Update Rollup.
- Reboot the machine.
- Ensure the Windows Update Service is running
- Attempt Windows Updates again.
Note: The fix for Windows 8.1 x64 also applies to Windows Server 2012 R2.
Applies to:
- All Stone Products running Windows 7 SP1, Windows 8.1 (with Update) - (all running 32bit - x86 - or 64bit), or Windows Server 2012 R2.