Problem
The products in the title may have issues with LAN port connectivity when used with certain driver versions under Windows 7, Vista and Windows XP.
Issue
Symptoms of this issue are:
- System(s) that were previously working fine now have no network connectivity
- For example, the system cannot obtain an IP address
- Or the system cannot contact the server
- Cold or warm reboots do not restore connectivity
Root Cause
The root cause is an out of date Realtek LAN controller driver. Affected driver versions are:
- Windows XP - Any version lower than 5.736.xxx.xxxx
- Windows Vista - Any version lower than 6.227.xxx.xxxx
- Windows 7 - Any version lower than 7.006.xxx.xxxx
If your driver version is the version above or higher, then you are likely not affected by this issue. Please contact the Stone service desk for assistance for additional troubleshooting.
An example of a driver that will cause this problem is shown below:
Resolution
Step 1:
The driver must be upgraded to a newer version, by obtaining a newer version from the Stone driver finder or from the Intel web site. If you need network connectivity to do this, please do Step 2 first, then update the driver, and then repeat Step 2.
Step 2:
The LAN PHY chip must be reset. To do this after having updated the driver, perform the following:
- Shut Windows down
- Disconnect the mains from the power supply
- Disconnect the LAN cable
- Wait for at least 10 seconds for the system to completely discharge
- Reconnect the LAN cable and then the power
Note: If you do not complete Step 2 after updating the driver then the problem may re-occur as the LAN chip programming has not been cleared. The LAN chip is programmed by the driver; step 2 must be completed after updating the driver.
Applies to:
- Systems with the Intel desktop motherboards DG41AN, DG41TX and DG41RQ