Acer Tablet Switch 10 - Recovery Mode Touchscreen and Dockable Keyboard May not Work

Problem

Customer that boot their Acer Switch 10 into recovery mode may find that the Touchscreen and dock may not function, resulting in recovery not being possible.

Cause

This is caused by the Windows Recovery Environment (WinRE) on the Switch 10 not including the necessary Intel I/O Drivers, resulting in the touchscreen not working.

Work Around

(For a permanent Resolution, which requires that the machine still boots Windows normally, see below)

Ensure that the dockable keyboard is plugged in before you turn the tablet on. The same applies to a USB mouse. Whilst this will not enable the touchscreen it should allow the recovery process to be completed.

If you are already in the Windows Recovery Environment and cannot use the keyboard, follow these steps to restart the Recovery or Reset Process.

Method 1 - Windows No Longer Boots Normally

Method 2 - Windows still boots normally

Method 3 - Last Resort

Resolution

A patch is available to add the Intel I/O drivers into the Windows Recovery Environment. This patch can only be installed if regular Windows is still booting. Download the patch here. After running the patch, restart the Recovery process as required.

Applies to:



Article ID: 389
Last updated: 02 Dec, 2014
Revision: 10
Third Party Products -> Acer Laptops, Netbooks and Tablets -> Troubleshooting -> Acer Tablet Switch 10 - Recovery Mode Touchscreen and Dockable Keyboard May not Work
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