Wireless Hints and Tips

Laptops connected to a Radius or Authenticated Wireless System Loses its Wireless Connection on Resume from Sleep

Problem

Consider the following scenario:

Cause

This issue may be caused by a timing or compatibility issue between some wireless network adapters with their corresponding drivers, and some wireless access points.

Resolution

There are two potential resolutions for this problem. One or both may need to be applied.

Resolution 1 - Ensure you are using an Up to Date Wireless Driver

This problem has been seen on Intel AC 7260 Wireless cards using driver 17.10.xx and older.

To resolve this issue, upgrade to driver 17.13.11 or newer for the Intel 7260 range:

Resolution 2 - Disable the Fast Reconnect Feature 

Instructions for Windows 7:

Reminder: This problem and solution does not apply to most home networks which are using simple WPA/TKIP or WPA2/AES encryption and basic authentication. This problem and solution only applies to RADIUS or similar enterprise authentication systems.

Additional Information

Applies to:


Intel 7260 Wireless Adapter Intermittently Disconnects from Wireless Network

Symptoms

Potential Cause

These issues can be caused by the crashing of the Windows Wireless LAN Service, potentially because of an Intel PROSet extension issue. Use the instructions below to confirm if this is the cause of your problems, and then the potential resolutions.

Confirm Your Issue is Caused by the Service Crash

Check the Windows Application Logs using Event Viewer, for signs of the "WLANExt.exe" application crashing, or "faulting". This will be shown as an "Application Error". Compare the date and time of these crashes to see if they match the losses of wireless connectivity.

This application crash can cause the Windows "WLAN AutoConfig" service to fail. Without this service, Wireless network connectivity may not be possible. The default Windows settings will recover the first two crashes of this service. After the third crash, access to Wireless networks may not be possible.

Note that reports in the Windows System log that the "WLAN Extensibility Module has stopped" may not be indicative of this problem, as this module may not be in use.

Cause

It is likely that the Intel PROSet Wireless additions are causing the problem. This appears to be able to happen even if the Intel PROSet Connection features are not in use. These features are visible from the Wireless connections properties in Windows 7.

This problem has been seen on version 17.0.5.8 of the wireless driver with PROSet.

Resolutions and Work-Arounds

Driver and PROSet Upgrade

Alternatively - Install the Driver without PROSet

The version 19.20 driver without PROSet can also be download here:

Issues Not Covered by this Article

Note: If you are experiencing the symptoms not covered by this article you may still benefit from the Wireless driver update above.

Applies to:


Using a Laptop in a Domain - Improving the Reliability of Wireless Connections on Windows 7

This article describes some methods to deal with wireless system performance or stability issues of a laptop system when used in a Microsoft Domain.

Problems and Solutions

Please contact Stone support if you need assistance with any of the times above which are not documented in this article.

Disable Wireless LAN Adapter power management

Use this solution to prevent users not being able to log into the domain.

Manual Method

Deployment Method

Use this method to configure lots of machines across your network at the same time.

Note: Bear in mind that the script method also removes the setting from wired LAN adapters. Please test this in your environment before deploying the script out across your machines.

Ensuring that the Wireless Network Profile is Available to All Users

This ensures that the wireless connection is available to Windows before anyone logs on. This setting is worth checking if domain networking works fine over a cable but not over wireless, even though the wireless appears to be working fine if you login as an Administrator.

To check this setting, you need to open up the properties of the wireless network.

Netlogon 5719 Fix

Note: These fixes require thorough testing before deployment. Test them, applying them in one by one in order. Use the minimum number of fixes you can to resolve your issue. Ensure that machines still function appropriately offline, or outside of the network (i.e. at home) as required.

Group Policy

Computer Configuration > Administrative Templates > Logon > Always wait for the network at computer startup and logon: Enable

Registry

For more information see here.

Applies to:



Stone Branded Products -> Laptops, Netbooks and Tablets -> Troubleshooting -> Wireless Hints and Tips
https://kb.stonegroup.co.uk/index.php?CategoryID=134