Troubleshooting

Acer Aspire Switch10 (SW5-011) Won't Switch on

Problem

Sometimes you may find that when you switch on your Acer Aspire Switch10 you get no signs of life, regardless of how long the unit has been on charge or if it is plugged into the mains.

Cause

This is caused by the battery being in a state known as deep discharge. The battery is completely exhausted. This may happen if the unit shut down due to the battery being flat, and then either it was not recharged for some time, or attempts were made to turn the unit on whilst the battery was flat.

Instructions

To restore the unit to working operation, carry out the following:

  1. Plug the tablet into the mains power supply.
  2. Press and hold the Power and Volume UP buttons at the same time. Hold them for between 30-60 seconds.
  3. The unit should now boot normally.

Note: Simply pressing the power button to turn the unit off when you have finished using it does NOT turn the device off. This simply puts it to sleep mode. The battery will continue to drain and can contribute towards this problem occurring. If the unit is not going to be used for some time and is not let on charge, it may be better to shut the unit down. To do this, please draw your finger from the right of the screen to open the charms menu, Select "Settings" (Gear icon near the bottom), then "Power" (Power symbol near the bottom in the middle) then "Shut down".

  

Applies to:


Acer Travelmate P258-M Won't PXE Boot or is Very Slow to Transfer System Images

Problem

Cause

This issue is caused by a problem with the Intel Management Engine firmware. Acer have released a new Management Engine firmware and BIOS combination to solve this problem. The new BIOS is version 1.16.

Resolution

Download the replacement Acer P258-M Management Engine Firmware and BIOS combination, and follow the upgrade instructions attached or included with the download.

Note: Please ensure you follow the flashing instructions precisely. Flashing the BIOS component without the Management engine upgrade may not resolve the issue and could lead to other problems.

Applies to:


Acer Tablet Switch 10 - Recovery Mode Touchscreen and Dockable Keyboard May not Work

Problem

Customer that boot their Acer Switch 10 into recovery mode may find that the Touchscreen and dock may not function, resulting in recovery not being possible.

Cause

This is caused by the Windows Recovery Environment (WinRE) on the Switch 10 not including the necessary Intel I/O Drivers, resulting in the touchscreen not working.

Work Around

(For a permanent Resolution, which requires that the machine still boots Windows normally, see below)

Ensure that the dockable keyboard is plugged in before you turn the tablet on. The same applies to a USB mouse. Whilst this will not enable the touchscreen it should allow the recovery process to be completed.

If you are already in the Windows Recovery Environment and cannot use the keyboard, follow these steps to restart the Recovery or Reset Process.

Method 1 - Windows No Longer Boots Normally

Method 2 - Windows still boots normally

Method 3 - Last Resort

Resolution

A patch is available to add the Intel I/O drivers into the Windows Recovery Environment. This patch can only be installed if regular Windows is still booting. Download the patch here. After running the patch, restart the Recovery process as required.

Applies to:



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