How to Solve No LAN Connectivity during Windows Setup on CC3

Problem

During the graphical (GUI) part of Windows Setup on CC3, the machine doesn't get a network Connection. Even though the DDU installs and appears to install the correct LAN driver, LAN connectivity is available until the machine is rebooted. Rebooting the machine during the build process breaks the build process from fully completing.

This problem occurs on machines manufactured in 2012 and 2013 that have a Realtek LAN Controller.

Cause

The cause is the Realtek LAN driver that is installed by CC3 early during installation. This driver is installed as it has a matching base device ID, however this driver does not properly support the Realtek LAN controller that is present, resulting in no functioning network connection. Because an old driver is installed, when the Stone DDU installs a new driver Windows XP automatically requests a restart before the new driver can take effect.

Resolution

This issue can be resolved by upgrading some of the native CC3 drivers to more modern versions. This can be done either by installing the latest CC3 Hardware support pack, or by using the Stone DDU Realtek NIC Hotfix utility. This utility upgrades the Realtek LAN drivers in the PC201LAN and c_Novatec1 subfolders in the build area:

Note: We recommend that you take a backup copy of these folders before using the upgrade utility, as this upgrade cannot be uninstalled.

Instructions

Applies to:



Article ID: 167
Last updated: 13 Feb, 2016
Revision: 10
Stone Branded Products -> Stone Software Products -> DDU for CC3 -> How to Solve No LAN Connectivity during Windows Setup on CC3
https://kb.stonegroup.co.uk/index.php?View=entry&EntryID=167