Problem
Customer that boot their Acer Switch 10 into recovery mode may find that the Touchscreen and dock may not function, resulting in recovery not being possible.
Cause
This is caused by the Windows Recovery Environment (WinRE) on the Switch 10 not including the necessary Intel I/O Drivers, resulting in the touchscreen not working.
Work Around
(For a permanent Resolution, which requires that the machine still boots Windows normally, see below)
Ensure that the dockable keyboard is plugged in before you turn the tablet on. The same applies to a USB mouse. Whilst this will not enable the touchscreen it should allow the recovery process to be completed.
If you are already in the Windows Recovery Environment and cannot use the keyboard, follow these steps to restart the Recovery or Reset Process.
Method 1 - Windows No Longer Boots Normally
- Hold down the power switch for 10 second to turn the unit off.
- Connect the dockable keyboard (and mouse if available).
- Turn the unit back on.
- Hold down the ALT key on the keyboard and then tap the F10 key.
- When you get the Recovery Screen, use the Advanced Repair options choice.
- Then use the Troubleshoot option.
- You can now use the Refresh or Reset options and can use the dockable keyboard and mouse to go through the process.
Method 2 - Windows still boots normally
- Hold down the power switch for 10 second to turn the unit off.
- Connect the dockable keyboard (and mouse if available).
- Turn the unit back on.
- Boot back into normal Windows.
- Restart Windows, but when you click on the Restart option hold down the Shift Key.
- Windows will now boot into the Recovery screen allowing you to use Troubleshoot, and then Reset or Refresh.
Method 3 - Last Resort
- Hold down the power switch for 10 second to turn the unit off.
- Connect the dockable keyboard (and mouse if available).
- Turn the unit back on.
- The system will start booting normal Windows, if this is still available. At this point, turn the unit off as early as possible during the Windows startup process.
- Repeat this three times.
- After this, when you let the system boot, Windows will report that it is starting the automatic repair process, and will again let you refresh or reset the system.
A patch is available to add the Intel I/O drivers into the Windows Recovery Environment. This patch can only be installed if regular Windows is still booting. Download the patch here. After running the patch, restart the Recovery process as required.
Applies to: